SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   HylaFAX Vendors:   Hylafax.org
HylaFAX+ Heap Overflow May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1029119
SecurityTracker URL:  http://securitytracker.com/id/1029119
CVE Reference:   CVE-2013-5680   (Links to External Site)
Date:  Oct 1 2013
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.2.4 through 5.5.3
Description:   A vulnerability was reported in HylaFAX+. A remote user can execute arbitrary code on the target system.

On systems where HylaFAX+ is configured for LDAP authentication support, a remote user can send specially crafted data to trigger a heap overflow and potentially execute arbitrary code on the target system. The code will run with the privileges of the target 'hfaxd' service (typically 'uucp' privileges).

The vendor was notified on July 22, 2013.

Dennis Jenkins reported this vulnerability.

Impact:   A remote user may be able to execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (5.5.4).
Vendor URL:  hylafax.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC