SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Rails Vendors:   rubyforge.org
Rails Serialized Attributes Processing Flaw Lets Remote Users Execute Arbitrary Code and Deny Service
SecurityTracker Alert ID:  1028109
SecurityTracker URL:  http://securitytracker.com/id/1028109
CVE Reference:   CVE-2013-0277   (Links to External Site)
Date:  Feb 11 2013
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.3.x, 3.0.x
Description:   A vulnerability was reported in Rails. A remote user can execute arbitrary code or cause denial of service conditions on the target system.

A remote user can send specially crafted data to trigger a YAML serialization flaw and potentially execute arbitrary code or deny service.

Applications that allow remote users to directly assign to the serialized fields in their models are affected.

Tobias Kraze reported this vulnerability.

Impact:   A remote user can execute arbitrary code or cause denial of service conditions on the target system.
Solution:   The vendor has issued a fix (2.3.17).

Patches are also available for versions 2.3.x and 3.0.x.

The vendor's advisory is available at:

http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/

Vendor URL:  weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC