SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Symantec Endpoint Protection Vendors:   Symantec
Symantec Endpoint Protection Bugs Let Remote Users Delete Files and Execute Arbitrary Code and Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1027093
SecurityTracker URL:  http://securitytracker.com/id/1027093
CVE Reference:   CVE-2012-0289, CVE-2012-0294, CVE-2012-0295   (Links to External Site)
Date:  May 23 2012
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, Modification of user information, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 12.1 RU1-MP1
Description:   Several vulnerabilities were reported in Symantec Endpoint Protection. A remote user can delete files on the target system. A remote user can execute arbitrary code on the target system. A local user can obtain elevated privileges on the target system.

A remote user can exploit a flaw in a service on the target Manager console to traverse the directory and delete files on the target system [CVE-2012-0294]. Version 12.1 is affected.

A remote user can then insert and execute arbitrary code with System privileges [CVE-2012-0295]. Version 12.1 is affected.

Andrea Micalizzi, aka rgod, reported these vulnerabilities via TippingPoint's ZeroDay Initiative.

A local user can trigger a buffer overflow in a function on Symantec Network Access Control and Symantec Endpoint Protection to execute arbitrary code on the target system with elevated privileges [CVE-2012-0289].

Anil Aphale, aka 41.w4r10r, with ControlCase India Pvt Ltd reported this vulnerability.

Impact:   A remote user can delete files on the target system and execute arbitrary code on the target system.

A local user can obtain elevated privileges on the target system.

Solution:   The vendor has issued a fix (SEP 12.1 RU1-MP1).

[Editor's note: Some of the vulnerabilities were corrected in prior versions.]

The vendor's advisory is available at:

http://www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=2012&suid=20120522_01

Vendor URL:  www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=2012&suid=20120522_01 (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC