SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Net-snmp Vendors:   net-snmp.sourceforge.net
Net-snmp handle_nsExtendOutput2Table() Array Index Error Lets Remote Users Deny Service
SecurityTracker Alert ID:  1026984
SecurityTracker URL:  http://securitytracker.com/id/1026984
CVE Reference:   CVE-2012-2141   (Links to External Site)
Date:  Apr 26 2012
Impact:   Denial of service via network
Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 5.7.1
Description:   A vulnerability was reported in Net-snmp. A remote user can cause denial of service conditions.

A remote user with read privileges for a MIB subtree can send a specially crafted SNMP GET request for a non-existent extension table entry to cause the target service to crash.

Impact:   A remote user can cause the target SNMP service to crash.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.net-snmp.org/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 20 2012 (Red Hat Issues Fix) Net-snmp handle_nsExtendOutput2Table() Array Index Error Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Dec 23 2014 (Oracle Issues Fix for Solaris) Net-snmp handle_nsExtendOutput2Table() Array Index Error Lets Remote Users Deny Service
Oracle has issued a fix for Solaris 11.2.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC