SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Web Server/CGI)  >   nginx Vendors:   nginx.org
nginx Buffer Overflow in ngx_http_mp4_module Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026924
SecurityTracker URL:  http://securitytracker.com/id/1026924
CVE Reference:   CVE-2012-2089   (Links to External Site)
Date:  Apr 13 2012
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0.7 - 1.0.14; 1.1.3 - 1.1.18
Description:   A vulnerability was reported in nginx. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a buffer overflow in ngx_http_mp4_module and execute arbitrary code on the target system. The code will run with the privileges of the target service.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (1.0.15, 1.1.19).

The vendor's advisory is available at:

http://nginx.org/en/security_advisories.html

Vendor URL:  nginx.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC