SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
Mozilla Thunderbird Multiple Bugs Let Remote Users Execute Arbitrary Code and Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1026804
SecurityTracker URL:  http://securitytracker.com/id/1026804
CVE Reference:   CVE-2012-0451, CVE-2012-0454, CVE-2012-0455, CVE-2012-0456, CVE-2012-0457, CVE-2012-0458, CVE-2012-0459, CVE-2012-0460, CVE-2012-0461, CVE-2012-0462, CVE-2012-0463, CVE-2012-0464   (Links to External Site)
Date:  Mar 14 2012
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 11
Description:   Multiple vulnerabilities were reported in Mozilla Thunderbird. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can conduct cross-site scripting attacks.

A remote user can create specially crafted HTML that, when loaded by the target user, will trigger a memory corruption error and execute arbitrary code on the target system [CVE-2012-0461, CVE-2012-0462, CVE-2012-0463, CVE-2012-0464]. The code will run with the privileges of the target user.

When a parent window spawns and closes a child window that uses the file open dialog, a use-after-free error may occur in 'shlwapi.dll' on 32-bit Windows 7 systems and potentially execute arbitrary code [CVE-2012-0454].

A drag and drop of javascript: links onto a frame may allow a remote user to conduct cross-site scripting attacks [CVE-2012-0455].

A remote user can can trigger a use-after-free in SVG animation to execute arbitrary code [CVE-2012-0457].

A remote user can trigger an out-of-bounds memory read in SVGFilter to obtain potentially sensitive information [CVE-2012-0456].

A remote user can use a carriage return linefeed injection attacks to introduce new Content Security Policy (CSP) headers and conduct cross-site scripting attacks against sites that have a separate header injection vulnerability [CVE-2012-0451]. Thunderbird 3.1 is not affected by this vulnerability.

A remote user may be able to cause a target user to set their home page to a javascript: URL through a drag and drop action [CVE-2012-0458].

A remote user can access keyframe's cssText after dynamic modification to potentially execute arbitrary code [CVE-2012-0459]. Thunderbird 3.1 is not affected by this vulnerability.

A remote user can spoof UI elements via the window.fullScreen API [CVE-2012-0460]. Thunderbird 3.1 are not affected by this vulnerability.

Bob Clary, Christian Holler, Jesse Ruderman, Nils, Michael Bebenita, Dindog, David Anderson, Jeff Walden, Vincenzo Iozzo and Willem Pinckaers (via TippingPoint's Zero Day Initiative Pwn2Own contest), Masayuki Nakano, Matt Brubeck, Daniel Glazman of Disruptive Innovations, Mariusz Mlynski, Mike Brooks of Sitewatch, Atte Kettunen from OUSPG, Soroush Dalili, and Blair Strang and Scott Bell of Security Assessment reported these vulnerabilities.

Impact:   A remote user can create HTML that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the target site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued a fix (3.1.20, ESR 10.0.3, 11.0).

The vendor's advisories are available at:

http://www.mozilla.org/security/announce/2012/mfsa2012-12.html
http://www.mozilla.org/security/announce/2012/mfsa2012-13.html
http://www.mozilla.org/security/announce/2012/mfsa2012-14.html
http://www.mozilla.org/security/announce/2012/mfsa2012-15.html
http://www.mozilla.org/security/announce/2012/mfsa2012-16.html
http://www.mozilla.org/security/announce/2012/mfsa2012-17.html
http://www.mozilla.org/security/announce/2012/mfsa2012-18.html
http://www.mozilla.org/security/announce/2012/mfsa2012-19.html

Vendor URL:  www.mozilla.org/security/announce/2012/mfsa2012-19.html (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Mar 14 2012 (Red Hat Issues Fix) Mozilla Thunderbird Multiple Bugs Let Remote Users Execute Arbitrary Code and Conduct Cross-Site Scripting Attacks
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC