SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CVS Vendors:   GNU [multiple authors]
CVS Heap Overflow in proxy_connect() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026719
SecurityTracker URL:  http://securitytracker.com/id/1026719
CVE Reference:   CVE-2012-0804   (Links to External Site)
Date:  Feb 22 2012
Impact:   Execution of arbitrary code via network, User access via network

Version(s): 1.11.23
Description:   A vulnerability was reported in CVS. A remote user can execute arbitrary code on the target system.

A remote HTTP proxy server can return a specially crafted HTTP response code to trigger a heap overflow and execute arbitrary code on the target client system.

The vulnerability resides in the proxy_connect() function in 'src/client.c'.

Impact:   A remote HTTP proxy server can execute arbitrary code on the target system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.nongnu.org/cvs/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 22 2012 (Red Hat Issues Fix) CVS Heap Overflow in proxy_connect() Lets Remote Users Execute Arbitrary Code
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC