SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Squid Vendors:   Squid-cache.org
Squid Gopher Response Memory Corruption Error Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025981
SecurityTracker URL:  http://securitytracker.com/id/1025981
CVE Reference:   CVE-2011-3205   (Links to External Site)
Updated:  Sep 9 2011
Original Entry Date:  Aug 29 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 3.0.x prior to 3.0.STABLE26, 3.1.x prior to 3.1.15, 3.2.x prior to 3.2.0.11
Description:   A vulnerability was reported in Squid. A remote user can cause denial of service conditions.

A remote Gopher server can return a specially crafted response longer than 4096 bytes to trigger a memory corruption error and cause the target Squid service to crash.

Ben Hawkes, Google Security Team, reported this vulnerability.

Impact:   A remote user can cause Squid to restart.
Solution:   The vendor has issued a fix (3.0.STABLE26, 3.1.15, 3.2.0.11).

The vendor's advisory is available at:

http://www.squid-cache.org/Advisories/SQUID-2011_3.txt

Vendor URL:  www.squid-cache.org/Advisories/SQUID-2011_3.txt (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 14 2011 (Red Hat Issues Fix) Squid Gopher Response Memory Corruption Error Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC