SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Glibc Vendors:   GNU [multiple authors]
Glibc Integer Overflow in fnmatch() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025450
SecurityTracker URL:  http://securitytracker.com/id/1025450
CVE Reference:   CVE-2011-1659   (Links to External Site)
Date:  Apr 28 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.13 and prior
Description:   A vulnerability was reported in Glibc. A remote user can cause denial of service conditions.

A remote user can send specially crafted UTF8 string data that, when processed by the target application, may cause the target application to crash. Applications that provide user-supplied data to the fnmatch() function are affected.

Impact:   A remote user can cause the target application to crash.
Solution:   The vendor has issued a source code fix, available at:

http://sourceware.org/git/?p=glibc.git;a=commit;h=8126d90480fa3e0c5c5cd0d02cb1c93174b45485

Vendor URL:  www.gnu.org/software/libc/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 13 2011 (VMware Issues Fix for ESX) Glibc Integer Overflow in fnmatch() Lets Remote Users Deny Service
VMware has issued a fix for ESX Server.
Feb 14 2012 (Red Hat Issues Fix) Glibc Integer Overflow in fnmatch() Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 4.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC