SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (File Transfer/Sharing)  >   OpenAFS Vendors:   OpenAFS.org
OpenAFS Bugs Let Remote Users Deny Service and May Let Remote Users Execute Arbitary Code
SecurityTracker Alert ID:  1025095
SecurityTracker URL:  http://securitytracker.com/id/1025095
CVE Reference:   CVE-2011-0430, CVE-2011-0431   (Links to External Site)
Date:  Feb 18 2011
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.4.14
Description:   Two vulnerabilities were reported in OpenAFS. A remote user can cause denial of service conditions. A remote user may be able to execute arbitrary code.

A remote user can send specially crafted ASN1-encoded data to trigger a double free in the Rx server process and cause the target service to crash or potentially execute arbitrary code [CVE-2011-0430]. Andrew Deason reported this vulnerability.

A user can trigger a flaw in the kernel module error handling to cause denial of service conditions [CVE-2011-0431].

Impact:   A remote user can cause denial of service conditions.

A remote user may be able to execute arbitrary code on the target system.

Solution:   The vendor has issued a fix (1.4.14).
Vendor URL:  www.openafs.org/ (Links to External Site)
Cause:   Access control error, Exception handling error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC