SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   OpenSSL Vendors:   OpenSSL.org
OpenSSL ClientHello Parsing Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025050
SecurityTracker URL:  http://securitytracker.com/id/1025050
CVE Reference:   CVE-2011-0014   (Links to External Site)
Date:  Feb 9 2011
Impact:   Denial of service via network, Disclosure of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 0.9.8h through 0.9.8q, 1.0.0 through 1.0.0c
Description:   A vulnerability was reported in OpenSSL. A remote user can cause denial of service conditions. An application may be able to obtain potentially sensitive information.

A remote user can send a specially crafted ClientHello handshake message to cause the target service to crash.

An application using OpenSSL may be able to obtain potentially sensitive information, such as an OCSP nonce extension, from memory.

Applications that act as a server and call SSL_CTX_set_tlsext_status_cb on the server's SSL_CTX (e.g., Apache httpd >= 2.3.3) are affected.

The vulnerability resides in 'ssl/t1_lib.c'.

Neel Mehta (Google) reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.

An application may be able to obtain potentially sensitive information.

Solution:   The vendor has issued a fix (0.9.8r, 1.0.0d).

The vendor's advisory is available at:

http://www.openssl.org/news/secadv_20110208.txt

Vendor URL:  www.openssl.org/news/secadv_20110208.txt (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 20 2011 (Red Hat Issues Fix) OpenSSL ClientHello Parsing Flaw Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Jul 29 2011 (HP Issues Fix for HP-UX) OpenSSL ClientHello Parsing Flaw Lets Remote Users Deny Service
HP issues fix for HP-UX 11.11, 11.23, and 11.31.
Nov 5 2011 (IBM Issues Fix for AIX) OpenSSL ClientHello Parsing Flaw Lets Remote Users Deny Service
IBM has issued a fix for AIX 5.3, 6.1, and 7.1.
Feb 2 2012 (Blue Coat Issues Fix for Reporter) OpenSSL ClientHello Parsing Flaw Lets Remote Users Deny Service
Bluecoat has issued a fix for Bluecoat Reporter.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC