SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   Mozilla Firefox Vendors:   Mozilla.org
Mozilla Firefox Input Validation Flaw Lets Remote Users Bypass Cross-Site Scripting Protections
SecurityTracker Alert ID:  1024851
SecurityTracker URL:  http://securitytracker.com/id/1024851
CVE Reference:   CVE-2010-3770   (Links to External Site)
Date:  Dec 10 2010
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.5 prior to 3.5.16, 3.6 prior to 3.6.13
Description:   A vulnerability was reported in Mozilla Firefox. A remote user can bypass cross-site scripting protections.

A remote user can use x-mac-arabic, x-mac-farsi, and x-mac-hebrew character encodings to bypass cross-site scripting protections.

Yosuke Hasegawa and Masatoshi Kimura reported this vulnerability.

Impact:   A remote user can bypass cross-site scripting protections.
Solution:   The vendor has issued a fix (3.5.16, 3.6.13).

The vendor's advisory is available at:

http://www.mozilla.org/security/announce/2010/mfsa2010-84.html

Vendor URL:  www.mozilla.org/security/announce/2010/mfsa2010-84.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Dec 10 2010 (Red Hat Issues Fix) Mozilla Firefox Input Validation Flaw Lets Remote Users Bypass Cross-Site Scripting Protections
Red Hat has issued a fix for Red Hat Enterprise Linux 4, 5, and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC