SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Multimedia)  >   Apple QuickTime Vendors:   Apple
Apple QuickTime Multiple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024830
SecurityTracker URL:  http://securitytracker.com/id/1024830
CVE Reference:   CVE-2010-1508, CVE-2010-3800, CVE-2010-3801, CVE-2010-3802, CVE-2010-4009   (Links to External Site)
Date:  Dec 7 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 7.6.9
Description:   A vulnerability was reported in Apple QuickTime. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted file that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

Specially crafted movie files can trigger a heap overflow in the processing of Track header atoms [CVE-2010-1508]. Only Windows-based systems are affected.

A specially crafted PICT file can trigger a memory corruption error [CVE-2010-3800].

A specially crafted FlashPix image can trigger a memory corruption error [CVE-2010-3801].

A specially crafted QTVR movie can trigger a memory corruption error [CVE-2010-3802].

A specially crafted movie file can trigger an integer overflow [CVE-2010-4009].

Moritz Jodeit of n.runs AG (via TippingPoint's Zero Day Initiative), Carsten Eiram of Secunia Research, Damian Put (via TippingPoint's Zero Day Initiative), Hossein Lotfi (s0lute) (via VeriSign iDefense Labs), Rodrigo Rubira Branco from the Check Point Vulnerability Discovery Team, an anonymous researcher (via TippingPoint's Zero Day Initiative), and Honggang Ren of Fortinet's FortiGuard Labs reported these vulnerabilities.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (7.6.9), available from the Software Update application, or from the QuickTime Downloads site:

http://www.apple.com/quicktime/download/

For Mac OS X v10.5.8
The download file is named: "QuickTime769Leopard.dmg"
Its SHA-1 digest is: b580bfb4a66484f3ca12bcaf6e4adfde57574e20

For Windows 7 / Vista / XP SP3
The download file is named: "QuickTimeInstaller.exe"
Its SHA-1 digest is: 1eec8904f041d9e0ad3459788bdb690e45dbc38e

QuickTime is incorporated into Mac OS X v10.6 and later.
QuickTime 7.6.9 is not presented to systems running
Mac OS X v10.6 or later.

The vendor's advisory is available at:

http://support.apple.com/kb/HT4447

Vendor URL:  support.apple.com/kb/HT4447 (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  UNIX (macOS/OS X), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC