SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Web Browser)  >   Mozilla Firefox Vendors:   Mozilla.org
Mozilla Firefox Heap Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024645
SecurityTracker URL:  http://securitytracker.com/id/1024645
CVE Reference:   CVE-2010-3765   (Links to External Site)
Updated:  Oct 28 2010
Original Entry Date:  Oct 27 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.5.x prior to 3.5.15, 3.6.x prior to 3.6.12
Description:   A vulnerability was reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted scripting code that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

Specially crafted document.write() and appendChild() calls can create duplicate text frames and overwrite buffers.

This vulnerability is being actively exploited on Windows-based systems.

Morten Krakvik of Telenor SOC reported this vulnerability.

Impact:   A remote user can create scripting code that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (3.5.15, 3.6.12).

The vendor's advisories are available at:

http://blog.mozilla.com/security/2010/10/26/critical-vulnerability-in-firefox-3-5-and-firefox-3-6/
http://www.mozilla.org/security/announce/2010/mfsa2010-73.html

Vendor URL:  www.mozilla.org/security/announce/2010/mfsa2010-73.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 28 2010 (Red Hat Issues Fix) Mozilla Firefox Heap Overflow Lets Remote Users Execute Arbitrary Code
Red Hat has issued a fix for Red Hat Enterprise Linux 4.
Oct 28 2010 (Red Hat Issues Fix for xulrunner) Mozilla Firefox Heap Overflow Lets Remote Users Execute Arbitrary Code
Red Hat has issued a fix for xulrunner for Red Hat Enterprise Linux 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC