SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   F-Secure Policy Manager Vendors:   F-Secure
F-Secure Policy Manager Input Validation Bug Permits Cross-Site Scripting Attacks Via the Expect Header
SecurityTracker Alert ID:  1024144
SecurityTracker URL:  http://securitytracker.com/id/1024144
CVE Reference:   CVE-2006-3918   (Links to External Site)
Date:  Jun 23 2010
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 8.00, 8.10, 8.11
Description:   A vulnerability was reported in F-Secure Policy Manager. A remote user can conduct cross-site scripting attacks.

A remote user can supply a specially crafted Expect header value that, when submitted by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the F-Secure Policy Manager software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the F-Secure Policy Manager software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix.

F-Secure Policy Manager Server for Windows 8.00:

ftp.f-secure.com/support/hotfix/fspm/fspm-8.00-hotfix-1-windows.zip

F-Secure Policy Manager Server for Linux 8.00:

ftp.f-secure.com/support/hotfix/fspm-linux/fspm-8.00-hotfix-1-linux.zip

F-Secure Policy Manager Server for Windows 8.10, 8.11:

ftp.f-secure.com/support/hotfix/fspm/fspm-8.1x-hotfix-2-windows.zip

F-Secure Policy Manager Server for Linux 8.10, 8.11:

ftp.f-secure.com/support/hotfix/fspm-linux/fspm-8.1x-hotfix-1-linux.zip

The vendor's advisory is available at:

http://www.f-secure.com/en_EMEA/support/security-advisory/fsc-2010-2.html

Vendor URL:  www.f-secure.com/en_EMEA/support/security-advisory/fsc-2010-2.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC