SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   NetBSD Vendors:   NetBSD
NetBSD OpenPAM passwd(1) May Let Certain Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1022432
SecurityTracker URL:  http://securitytracker.com/id/1022432
CVE Reference:   CVE-2009-2482   (Links to External Site)
Updated:  Jul 27 2009
Original Entry Date:  Jun 23 2009
Impact:   Modification of authentication information, Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.0, 4.0.1, 5.0
Description:   A vulnerability was reported in NetBSD. A local user may be able to obtain elevated privileges on the target system in certain cases.

The pam_unix authentication module allows a local non-root user with knowledge of the root password to invoke passwd(1) and change the password.

Thomas Getzke and Hubert Feyrer reported this vulnerability.

Impact:   A local non-root user with knowledge of the root password can change the root password.
Solution:   NetBSD has issued a fix.

The NetBSD advisory is available at:

http://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2009-004.txt.asc

Vendor URL:  ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2009-004.txt.asc (Links to External Site)
Cause:   Access control error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC