SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Ruby Vendors:   Matsumoto, Yukihiro
Ruby BigDecimal Conversion Bug May Let Remote Users Deny Service
SecurityTracker Alert ID:  1022371
SecurityTracker URL:  http://securitytracker.com/id/1022371
CVE Reference:   CVE-2009-1904   (Links to External Site)
Updated:  Jul 3 2009
Original Entry Date:  Jun 11 2009
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.8.6-p368, 1.8.7-p160; and prior versions
Description:   A vulnerability was reported in Ruby. A remote user can cause denial of service conditions.

A remote user can supply a specially crafted value to a function that converts BigDecimal objects into Float numbers to trigger a segmentation fault.

Impact:   A remote user can cause the target application to crash.
Solution:   The vendor has issued a fix (1.8.6-p369, 1.8.7-p173), available at:

ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.6-p369.tar.gz
ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p173.tar.gz

Version 1.9.1 is not affected.

The vendor's advisory is available at:

http://www.ruby-lang.org/en/news/2009/06/09/dos-vulnerability-in-bigdecimal/

Vendor URL:  www.ruby-lang.org/en/news/2009/06/09/dos-vulnerability-in-bigdecimal/ (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 3 2009 (Red Hat Issues Fix) Ruby BigDecimal Conversion Bug May Let Remote Users Deny Service
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC