SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CUPS Vendors:   Easy Software Products
CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1022326
SecurityTracker URL:  http://securitytracker.com/id/1022326
CVE Reference:   CVE-2009-0791   (Links to External Site)
Updated:  Nov 19 2009
Original Entry Date:  Jun 3 2009
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.2.0
Description:   A vulnerability was reported in CUPS. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted PDF file that, when printed by the target user, will cause 'pdftops' to crash or execute arbitrary code on the target system. The code will run with the privileges of the target server ('lp' privileges).

Impact:   A remote user can create a file that, when printed by the target user, will execute arbitrary code on the target system.
Solution:   The vendor has issued a fix, available at:

http://svn.easysw.com/public/cups/tags/release-1.2.0/pdftops/JBIG2Stream.cxx

Vendor URL:  www.cups.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 3 2009 (Red Hat Issues Fix) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for Red Hat Enterprise Linux 3 and 4.
Oct 15 2009 (Red Hat Issues Fix for xpdf) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for xpdf for Red Hat Enterprise Linux 3.
Oct 15 2009 (Red Hat Issues Fix for kdegraphics) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for kdegraphics for Red Hat Enterprise Linux 5.
Oct 15 2009 (Red Hat Issues Fix for xpdf) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for xpdf for Red Hat Enterprise Linux 4.
Oct 15 2009 (Red Hat Issues Fix for gpdf) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for gpdf for Red Hat Enterprise Linux 4.
Oct 15 2009 (Red Hat Issues Fix for kdegraphics) CUPS Integer Overflow in 'pdftops' Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for kdegraphics for Red Hat Enterprise Linux 4.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC