SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Printer)  >   Xerox WorkCentre Vendors:   Xerox
Xerox WorkCentre Command Injection Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1022238
SecurityTracker URL:  http://securitytracker.com/id/1022238
CVE Reference:   CVE-2009-1656   (Links to External Site)
Updated:  May 25 2009
Original Entry Date:  May 15 2009
Impact:   Execution of arbitrary code via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Xerox WorkCentre. A remote user can execute arbitrary code on the target system.

A remote user can submit specially crafted input to the web service to execute arbitrary code on the target device.

The vendor notes that customer and user passwords are not exposed.

The following WorkCentre products are affected:

232
238
245
255
265
275
5632
5638
5645
5655
5665
5675
5687
7655
7665
7675

The following WorkCentre Pro products are affected:

232
238
245
255
265
275

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix, available at:

http://www.xerox.com/downloads/usa/en/c/cert_P38v1_WCP275_WC7675_WC5687_Patch.zip

The vendor's advisory is available at:

http://www.xerox.com/downloads/usa/en/c/cert_XRX09-02_v1.0.pdf

Vendor URL:  www.xerox.com/downloads/usa/en/c/cert_XRX09-02_v1.0.pdf (Links to External Site)
Cause:   Input validation error, State error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC