SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   GnuTLS Vendors:   gnutls.org
GnuTLS Command Line Interface Does Not Properly Validate X.509 Certificates
SecurityTracker Alert ID:  1022159
SecurityTracker URL:  http://securitytracker.com/id/1022159
CVE Reference:   CVE-2009-1417   (Links to External Site)
Date:  May 1 2009
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in GnuTLS. The system may validate invalid certificates.

The gnutls-cli component does not check the activation and expiration dates of X.509 certificates.

Romain Francoise reported this vulnerability.

Impact:   The system may validate invalid certificates.
Solution:   The vendor has issued a patch, available at:

http://article.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/3517

Vendor URL:  www.gnu.org/software/gnutls/security.html (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC