SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   OpenBSD Kernel Vendors:   OpenBSD
OpenBSD bgpd Autonomous System Path Processing Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1021736
SecurityTracker URL:  http://securitytracker.com/id/1021736
CVE Reference:   CVE-2009-0780   (Links to External Site)
Updated:  Mar 9 2009
Original Entry Date:  Feb 19 2009
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 4.3, 4.4
Description:   A vulnerability was reported in OpenBSD bgpd. A remote user can cause denial of service conditions.

A remote user can send a specially crafted Autonomous System path value to cause the target bgpd(8) service to terminate.

The vulnerability resides in the aspath_prepend() function in 'usr.sbin/bgpd/rde_attr.c'.

Impact:   A remote user can cause the target bgpd daemon to crash.
Solution:   The vendor has issued the following patches:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.4/common/010_bgpd.patch
ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.3/common/010_bgpd.patch

Vendor URL:  www.openbsd.org/ (Links to External Site)
Cause:   State error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC