SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   Solaris Vendors:   Sun
Solaris Pseudo-Terminal Driver Race Condition Lets Local Users Deny Service
SecurityTracker Alert ID:  1021640
SecurityTracker URL:  http://securitytracker.com/id/1021640
CVE Reference:   CVE-2009-0268   (Links to External Site)
Updated:  Feb 9 2009
Original Entry Date:  Jan 28 2009
Impact:   Denial of service via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8, 9, 10, OpenSolaris
Description:   A vulnerability was reported in Solaris. A local user can cause denial of service conditions.

A local user can exploit a race condition in the Solaris pseudo-terminal driver (pty(7D)) module to to trigger a system panic.

Impact:   A local user can cause a system panic on the target system.
Solution:   Sun has issued the following fixes.

SPARC Platform

* Solaris 8 with patch 113685-07 or later
* Solaris 9 with patch 140426-01 or later
* Solaris 10 with patch 140383-01 or later
* OpenSolaris based upon builds snv_103 or later

x86 Platform

* Solaris 8 with patch 113686-06 or later
* Solaris 9 with patch 140427-01 or later
* Solaris 10 with patch 140384-01 or later
* OpenSolaris based upon builds snv_103 or later

The vendor's advisory is available at:

http://sunsolve.sun.com/search/document.do?assetkey=1-66-249586-1

Vendor URL:  sunsolve.sun.com/search/document.do?assetkey=1-66-249586-1 (Links to External Site)
Cause:   State error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC