SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Enscript (GNU) Vendors:   GNU [multiple authors]
GNU Enscript Buffer Overflows in Processing Special Escape Sequences Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1021401
SecurityTracker URL:  http://securitytracker.com/id/1021401
CVE Reference:   CVE-2008-3863, CVE-2008-4306, CVE-2008-5078   (Links to External Site)
Updated:  Dec 15 2008
Original Entry Date:  Dec 15 2008
Impact:   Execution of arbitrary code via network, User access via network

Version(s): 1.6.1 and prior versions; 1.6.4 beta
Description:   Several vulnerabilities were reported in GNU Enscript. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted ASCII file that, when loaded by the target user, will trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user.

Files opened with the "special escapes" option (-e or --escapes) enabled are affected.

The read_special_escape() function in 'src/psgen.c' is affected when processing the 'setfilename' sequence [CVE-2008-3863]. Secunia Research reported this vulnerability.

The read_special_escape() function in 'src/psgen.c' is affected when processing the 'font' sequence [CVE-2008-4306]. Secunia Research reported this vulnerability.

The recognize_eps_file() function in 'src/psgen.c' and the tilde_subst() function in 'src/util.c' are affected when processing a file name [CVE-2008-5078].

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.gnu.org/software/enscript/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Dec 15 2008 (Red Hat Issues Fix) GNU Enscript Buffer Overflows in Processing Special Escape Sequences Let Remote Users Execute Arbitrary Code
Red Hat has released a fix for Red Hat Enterprise Linux 2.1, 3, and 4.
Dec 15 2008 (Red Hat Issues Fix) GNU Enscript Buffer Overflows in Processing Special Escape Sequences Let Remote Users Execute Arbitrary Code
Red Hat has released a fix for Red Hat Enterprise Linux 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC