SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Ruby Vendors:   Matsumoto, Yukihiro
Ruby Safe Level Access Control Bug Lets Applications Bypass Certain Access Controls
SecurityTracker Alert ID:  1020656
SecurityTracker URL:  http://securitytracker.com/id/1020656
CVE Reference:   CVE-2008-3655   (Links to External Site)
Updated:  Aug 13 2008
Original Entry Date:  Aug 12 2008
Impact:   Disclosure of user information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.8.5, 1.8.6-p286, 1.8.7-p71, and prior versions; 1.9 r18423 and prior revisions
Description:   A vulnerability was reported in Ruby. An application can bypass certain safe level access restrictions.

An application running at safe level 4 can invoke the untrace_var() function.

An application running at safe level 4 can modify the $PROGRAM_NAME variable.

An application running at safe level 4 can perform syslog operations.

An application running at safe level 1 through 3 can invoke insecure methods.

Keita Yamaguchi reported these vulnerabilities.

Impact:   A user can bypass safe level access control restrictions.
Solution:   The vendor has issued a fix (1.8.6-p287, 1.8.7-p72), available at:

ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.6-p287.tar.gz
ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p72.tar.gz

The vendor's advisory is available at:

http://www.ruby-lang.org/en/news/2008/08/08/multiple-vulnerabilities-in-ruby/

Vendor URL:  www.ruby-lang.org/en/news/2008/08/08/multiple-vulnerabilities-in-ruby/ (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 21 2008 (Red Hat Issues Fix) Ruby Safe Level Access Control Bug Lets Applications Bypass Certain Access Controls
Red Hat has released a fix for Red Hat Enterprise Linux 2.1.
Oct 21 2008 (Red Hat Issues Fix) Ruby Safe Level Access Control Bug Lets Applications Bypass Certain Access Controls
Red Hat has released a fix for Red Hat Enterprise Linux 3.
Oct 21 2008 (Red Hat Issues Fix) Ruby Safe Level Access Control Bug Lets Applications Bypass Certain Access Controls
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC