SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Presenter Vendors:   Adobe Systems Incorporated
Adobe Presenter Input Validation Holes Permit Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1020645
SecurityTracker URL:  http://securitytracker.com/id/1020645
CVE Reference:   CVE-2008-3515, CVE-2008-3516   (Links to External Site)
Date:  Aug 11 2008
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6, 7
Description:   A vulnerability was reported in Adobe Presenter. A remote user can conduct cross-site scripting attacks.

Code generated by Adobe Presenter does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the code generated by Adobe Presenter and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The 'viewer.swf' and 'loadflash.js' files are affected.

Adi Sharabani, Ayal Yogev, and Yuval Baror from IBM Rational Application Security and Tavis Ormandy of the Google Security Team reported this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the code generated by Adobe Presenter, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix (Adobe Presenter 7.0.1 update), available at:

http://download.adobe.com/pub/adobe/presenter/win/adobe_presenter_patch_v701.exe

Previously generated content should be regenerated and redeployed.

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb08-17.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb08-17.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC