SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Instant Messaging/IRC/Chat)  >   Pidgin Vendors:   pidgin.im
Pidgin Integer Overflow in msn_slplink_process_msg() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1020451
SecurityTracker URL:  http://securitytracker.com/id/1020451
CVE Reference:   CVE-2008-2927   (Links to External Site)
Date:  Jul 9 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4.3
Description:   A vulnerability was reported in Pidgin. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted SLP message to trigger an integer overflow in the MSN protocol handler and execute arbitrary code on the target user's system. The code will run with the privileges of the target user.

The overflows reside in 'libpurple/protocols/msn/slplink.c' and 'libpurple/protocols/msnp9/slplink.c'.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed version (2.4.3).

No vendor advisory was available at the time of this entry.

Vendor URL:  pidgin.im/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 9 2008 (Red Hat Issues Fix) Pidgin Integer Overflow in msn_slplink_process_msg() Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for Red Hat Enterprise Linux 3, 4, and 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC