SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Multimedia)  >   Firefly Media Server Vendors:   fireflymediaserver.org
Firefly Media Server Integer Overflow in ws_getpostvars() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019908
SecurityTracker URL:  http://securitytracker.com/id/1019908
CVE Reference:   CVE-2008-1771   (Links to External Site)
Date:  Apr 21 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 0.2.4.2
Description:   A vulnerability was reported in Firefly Media Server. A remote user can execute arbitrary code on the target system.

A remote user can send an HTTP POST request with a specially crafted Content-Length value to trigger an integer overflow in ws_getpostvars() and execute arbitrary code on the target system. The code will run with the privileges of the target service.

Nico Golde reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed version (0.2.4.2).

The vendor's advisory is available at:

http://sourceforge.net/project/shownotes.php?release_id=593465&group_id=98211

Vendor URL:  www.fireflymediaserver.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC