SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Apache OpenOffice Vendors:   OpenOffice.org
OpenOffice Heap Overflow in Processing OLE Files Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019890
SecurityTracker URL:  http://securitytracker.com/id/1019890
CVE Reference:   CVE-2008-0320   (Links to External Site)
Date:  Apr 17 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4
Description:   A vulnerability was reported in OpenOffice.org Office Suite. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted OLE file that, when loaded by the target user, will trigger a heap overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user.

An anonymous researcher reported this vulnerability via iDefense.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fixed version (2.4).

The vendor's advisory is available at:

http://www.openoffice.org/security/cves/CVE-2008-0320.html

Vendor URL:  www.openoffice.org/security/cves/CVE-2008-0320.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 17 2008 (Red Hat Issues Fix) OpenOffice Heap Overflow in Processing OLE Files Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.
Apr 17 2008 (Red Hat Issues Fix) OpenOffice Heap Overflow in Processing OLE Files Lets Remote Users Execute Arbitrary Code
Red Hat has released a fix for openoffice.org 1.x for Red Hat Enterprise Linux 3 and 4.
Apr 28 2008 (Sun Issues Fix for StarOffice) OpenOffice Heap Overflow in Processing OLE Files Lets Remote Users Execute Arbitrary Code
Sun has issued a fix for StarOffice 8.
May 5 2008 (Sun Issues Fix for StarOffice) OpenOffice Heap Overflow in Processing OLE Files Lets Remote Users Execute Arbitrary Code
Sun has issued a fix for StarOffice 7 and 8.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC