SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   TIBCO Enterprise Message Service Vendors:   TIBCO Software
TIBCO Enterprise Message Service Buffer Overflows Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019826
SecurityTracker URL:  http://securitytracker.com/id/1019826
CVE Reference:   CVE-2008-1703, CVE-2008-1704   (Links to External Site)
Date:  Apr 11 2008
Impact:   Execution of arbitrary code via network, Root access via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 4.4.3
Description:   A vulnerability was reported in TIBCO Enterprise Message Service. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a buffer overflow in 'tibemsd' and execute arbitrary code on the target system. The code will run with the privileges of the target service. On Windows-based systems, this may be system level privileges.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed version (4.4.3).

The vendor's advisory is available at:

http://www.tibco.com/resources/mk/ems_security_advisory_20080409.txt

Vendor URL:  www.tibco.com/resources/mk/ems_security_advisory_20080409.txt (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), OS/400, UNIX (AIX), UNIX (HP/UX), UNIX (macOS/OS X), UNIX (Solaris - SunOS), Windows (2000), Windows (2003), Windows (XP), z/OS

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC