SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   HPE OpenView Network Node Manager Vendors:   HPE
HP OpenView Network Node Manager Buffer Overflow in ovspmd Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1019821
SecurityTracker URL:  http://securitytracker.com/id/1019821
CVE Reference:   CVE-2008-1842   (Links to External Site)
Updated:  Jun 11 2008
Original Entry Date:  Apr 9 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 8.01 and prior versions
Description:   A vulnerability was reported in HP OpenView Network Node Manager. A remote user can execute arbitrary code on the target system.

A remote user can send specially crafted data to the ovspmd service on port 8886 to trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target service.

A demonstration exploit is available at:

http://aluigi.org/poc/closedview.zip

Luigi Auriemma reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix. A patch matrix is available in the vendor's advisory.

The vendor's advisories are available at:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01466051
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01471755

Vendor URL:  h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01466051 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  Re: Multiple vulnerabilities in HP OpenView NNM 7.53

Forget the yesterday's advisory, the setup didn't installed the 7.53
patches from the ISO and so I was working on an old version.

The following is a new vulnerability tested on 7.53:

  http://aluigi.org/adv/closedview-adv.txt


--- 
Luigi Auriemma
http://aluigi.org

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC