SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VoIP)  >   Asterisk Vendors:   Digium (Linux Support Services)
Asterisk Predictable Session IDs May Let Remote Users Hijack HTTP Manager Sessions
SecurityTracker Alert ID:  1019679
SecurityTracker URL:  http://securitytracker.com/id/1019679
CVE Reference:   CVE-2008-1390   (Links to External Site)
Date:  Mar 20 2008
Impact:   User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.4.x prior to 1.4.19-rc3, 1.6.x prior to 1.6.0-beta6
Description:   A vulnerability was reported in Asterisk. A remote user may be able to hijack HTTP Manager sessions.

Manager session IDs are calculated in a manner that greatly reduces the number of guesses a remote user must make to predict the ID numbers.

The vendor was notified on February 25, 2008.

Dino A. Dai Zovi reported this vulnerability.

Impact:   A remote user may be able to hijack a web management session.
Solution:   The vendor has issued a fix (1.4.19-rc3, 1.6.0-beta6).

The vendor's advisory is available at:

http://downloads.digium.com/pub/security/AST-2008-005.html

Vendor URL:  downloads.digium.com/pub/security/AST-2008-005.html (Links to External Site)
Cause:   Randomization error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC