SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Symantec Anti Virus Vendors:   Symantec
Symantec Anti Virus Decomposer Memory Consumption and Buffer Overflow Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1019503
SecurityTracker URL:  http://securitytracker.com/id/1019503
CVE Reference:   CVE-2008-0308, CVE-2008-0309   (Links to External Site)
Updated:  Feb 26 2008
Original Entry Date:  Feb 26 2008
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.3.16.39 and prior versions
Description:   Two vulnerabilities were reported in Symantec Anti Virus in the Symantec Decomposer component. A remote user can cause denial of service conditions. A remote user may be able to cause arbitrary code to be executed on the target system.

A remote user can create a specially crafted RAR archive that, when processed by the target application, will cause excessive memory consumption [CVE-2008-0308].

A remote user can create a specially crafted RAR archive that, when processed by the target application, will trigger a buffer overflow and cause the Decomposer to crash or potentially execute arbitrary code [CVE-2008-0309].

The vulnerabilities can be triggered by sending the archive to the scan engine on TCP port 1134 using the Internet Content Adaptation Protocol (ICAP).

The following products are affected:

Symantec AntiVirus for Network Attached Storage
Symantec AntiVirus Scan Engine
Symantec AntiVirus Scan Engine for Caching
Symantec AntiVirus Scan Engine for Clearswift
Symantec AntiVirus Scan Engine for Messaging
Symantec AntiVirus Scan Engine for MS ISA
Symantec AntiVirus Scan Engine for MS SharePoint
Symantec AntiVirus/Filtering for Domino MPE(AIX, Linux, Solaris)

Symantec Mail Security for Microsoft Exchange and Symantec Scan Engine are also affected.

Symantec AntiVirus Corporate Edition is not affected.

The vendor was notified on June 14, 2007.

iDefense reported these vulnerabilities.

Impact:   A remote user can create a file that, when processed by the target application, will cause the application to crash or potentially execute arbitrary code.
Solution:   The vendor has issued a fixed version (4.3.18.43).

The vendor's advisory is available at:

http://securityresponse.symantec.com/avcenter/security/Content/2008.02.27.html

Vendor URL:  securityresponse.symantec.com/avcenter/security/Content/2008.02.27.html (Links to External Site)
Cause:   Boundary error, Resource error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC