SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Directory)  >   OpenLDAP Vendors:   OpenLDAP.org
OpenLDAP Lets Remote Authenticated Users Crash the slapd Daemon With Specially Crafted Modify Operations
SecurityTracker Alert ID:  1019480
SecurityTracker URL:  http://securitytracker.com/id/1019480
CVE Reference:   CVE-2007-6698   (Links to External Site)
Date:  Feb 22 2008
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.3.35 and prior versions
Description:   A vulnerability was reported in OpenLDAP. A remote authenticated user can cause denial of service conditions.

A remote authenticated user can send a specially crafted modify operation with the NOOP control set to critical to cause the target slapd service to crash.

Jonathan Clarke reported this vulnerability.

[Editor's note: This vulnerability was originally reported in April 2007.]

Impact:   A remote authenticated user can cause denial of service conditions on the target system.
Solution:   The vendor has issued a fixed version (2.3.36).
Vendor URL:  www.openldap.org/ (Links to External Site)
Cause:   State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 22 2008 (Red Hat Issues Fix) OpenLDAP Lets Remote Authenticated Users Crash the slapd Daemon With Specially Crafted Modify Operations
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC