SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VoIP)  >   Asterisk Vendors:   Digium (Linux Support Services)
Asterisk Input Validation Flaw in res_config_pgsql Lets Remote Users Inject SQL Commands
SecurityTracker Alert ID:  1019021
SecurityTracker URL:  http://securitytracker.com/id/1019021
CVE Reference:   CVE-2007-6171   (Links to External Site)
Date:  Nov 30 2007
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.4.15
Description:   A vulnerability was reported in Asterisk. A remote user can inject SQL commands.

The res_config_pgsql module does not properly validate user-supplied input. A remote user can supply specially crafted lookup data to execute SQL commands on the underlying administrative database, which contains usernames and passwords.

The vendor was notified on November 29, 2007.

P. Chisteas reported this vulnerability.

Impact:   A remote user can execute SQL commands on the underlying database.
Solution:   The vendor has issued a fixed version (1.4.15).

The Asterisk advisory is available at:

http://www.asterisk.org/node/48433

Vendor URL:  www.asterisk.org/node/48433 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC