SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Device (Encryption/VPN)  >   Citrix NetScaler Vendors:   Citrix
Citrix NetScaler Input Validation Hole in 'generic_api_call' Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1018981
SecurityTracker URL:  http://securitytracker.com/id/1018981
CVE Reference:   CVE-2007-6037   (Links to External Site)
Updated:  Nov 26 2007
Original Entry Date:  Nov 20 2007
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 8.0, build 47.8
Description:   A vulnerability was reported in Citrix NetScaler. A remote user can conduct cross-site scripting attacks.

The web management interface does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the Citrix NetScaler device and will run in the security context of that device. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the device, access data recently submitted by the target user via web form to the device, or take actions on the device acting as the target user.

The '/ws/generic_api_call.pl' script is affected.

A demonstration exploit URL is provided:

http://[target]/ws/generic_api_call.pl?function=statns&standalone=%3c/script%3e%3cscript%3ealert(document.cookie)%3c/script%3e%3cscript%3e

nnposter reported this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the Citrix NetScaler device, access data recently submitted by the target user via web form to the device, or take actions on the device acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.citrix.com/ (Links to External Site)
Cause:   Input validation error

Message History:   None.


 Source Message Contents

Subject:  Citrix NetScaler Web Management XSS

Citrix NetScaler Web Management XSS


Product: Citrix NetScaler
http://www.citrix.com/lang/English/ps2/index.asp


Citrix NetScaler contains a cross-site scripting vulnerability in the web management interface. None of the parameter values of /ws/generic_api_call.pl
 are sanitized before they get embedded in the HTML output. As an example, parameter "standalone" can be exploited as follows:

http://(target)/ws/generic_api_call.pl?function=statns&standalone=%3c/script%3e%3cscript%3ealert(document.cookie)%3c/script%3e%3cscript%3e


The vulnerability has been identified in version 8.0, build 47.8.
However, other versions may be also affected.


Solution:
Do not stay logged into the NetScaler web management interface while browsing other web sites.


Found by:
nnposter

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC