SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   IBM iNotes and Domino Vendors:   IBM
IBM Lotus Notes Buffer Overflows in File Attachment Viewer Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1018853
SecurityTracker URL:  http://securitytracker.com/id/1018853
CVE Reference:   CVE-2007-5909, CVE-2007-5910   (Links to External Site)
Updated:  Feb 18 2008
Original Entry Date:  Oct 23 2007
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6.5, 7.0, 8.0
Description:   Tan Chew Keong of vuln.sg reported several vulnerabilities in IBM Lotus Notes in the file attachment viewer. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted file that, when viewed by the target user, will trigger a buffer overflow in the file attachment viewer and execute arbitrary code on the target system. The code will run with the privileges of the target user.

A specially crafted DOC, SAM, WPD, or MIF file attachment can trigger an overflow.

IBM has assigned SPR numbers KEMG6X9QED, KEMG6XAS48, KEMG6XPK6A, and KEMG6XTLDN to these vulnerabilities.

The vendor was notified on January 5, 2007.

The original advisory is available at:

http://vuln.sg/lotusnotes702-en.html
http://vuln.sg/lotusnotes702-jp.html

Impact:   A remote user can create a file that, when viewed by the target user via the file attachment viewer, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (7.0.3 and planned for 8.0.1).

The IBM advisory is available at:

http://www-1.ibm.com/support/docview.wss?rs=899&uid=swg21271111

Vendor URL:  www-1.ibm.com/support/docview.wss?rs=899&uid=swg21271111 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  [vuln.sg] IBM Lotus Notes Attachment Viewer Buffer Overflow

[vuln.sg] Vulnerability Research Advisory

IBM Lotus Notes Attachment Viewer Buffer Overflow Vulnerabilities

by Tan Chew Keong
Release Date: 2007-10-23

Summary
-------
Multiple exploitable buffer overflow vulnerabilities were found within the file attachment viewer in IBM Lotus Notes. The vulnerabilities
 can be exploited to execute arbitrary code by tricking the user to view a malicious DOC, SAM, WPD, or MIF file attachment using the
 file attachment viewer in Lotus Notes.

Tested Versions
---------------
Lotus Notes 7.0.2 (Trial)

Details
-------
http://vuln.sg/lotusnotes702-en.html
http://vuln.sg/lotusnotes702-jp.html

Vendor's Technote
-----------------
http://www-1.ibm.com/support/docview.wss?rs=899&uid=swg21271111

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC