SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Oracle Java SE Vendors:   Sun
Java Runtime Environment Lets Remote Applets Gain Elevated Privileges
SecurityTracker Alert ID:  1018847
SecurityTracker URL:  http://securitytracker.com/id/1018847
CVE Reference:   CVE-2007-5689   (Links to External Site)
Updated:  Feb 18 2008
Original Entry Date:  Oct 23 2007
Impact:   Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.3.1_20 and prior, 1.4.2_15 and prior, 5.0 Update 12 and prior, 6 Update 2 and prior
Description:   A vulnerability was reported in Java Runtime Environment (JRE) in the Virtual Machine implementation. A remote user can read or write files or cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted applet that, when loaded by the target user, will trigger a flaw in the Virtual Machine and read or write local files or execute arbitrary applications on the target user's system. The code will run with the privileges of the target user.

Azul Systems, Inc. reported this vulnerability.

Impact:   A remote user can create an applet that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued the following fixed versions.

* JDK and JRE 6 Update 3 or later
* JDK and JRE 5.0 Update 13 or later
* SDK and JRE 1.4.2_16 or later

This issue is addressed in the following release for Windows and Solaris 8:

* SDK and JRE 1.3.1_21 or later

JDK and JRE 6 Update 3 is available for download at the following links:

http://java.sun.com/javase/downloads/index.jsp

http://java.com

JDK 6 Update 3 for Solaris is available in the following patches:

* Java SE 6 Update 3 (as delivered in patch 125136-04 or later)
* Java SE 6 Update 3 (as delivered in patch 125137-04 or later (64bit))
* Java SE 6_x86 Update 3 (as delivered in patch 125138-04 or later)
* Java SE 6_x86 Update 3 (as delivered in patch 125139-04 or later (64bit))

JDK and JRE 5.0 Update 13 is available for download at the following link:

http://java.sun.com/javase/downloads/index_jdk5.jsp

JDK 5.0 Update 13 for Solaris is available in the following patches:

* J2SE 5.0 Update 13 (as delivered in patch 118666-14)
* J2SE 5.0 Update 13 (as delivered in patch 118667-14 (64bit))
* J2SE 5.0_x86 Update 13 (as delivered in patch 118668-14)
* J2SE 5.0_x86 Update 13 (as delivered in patch 118669-14 (64bit))

SDK and JRE 1.4.2 is available for download at:

http://java.sun.com/j2se/1.4.2/download.html

SDK and JRE 1.3.1 for Solaris 8 is available for download at:

http://java.sun.com/j2se/1.3/download.html

The Sun advisory is available at:

http://sunsolve.sun.com/search/document.do?assetkey=1-26-103112-1

Vendor URL:  sunsolve.sun.com/search/document.do?assetkey=1-26-103112-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Solaris - SunOS), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 21 2008 (BEA Issues Fix for JRockit) Java Runtime Environment Lets Remote Applets Gain Elevated Privileges
A fix for BEA JRockit is available.
Jun 18 2008 (VMware Issues Fix for ESX Server) Java Runtime Environment Lets Remote Applets Gain Elevated Privileges
VMware has issued a fix for VMware ESX Server.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC