SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


Try our Premium Alert Service
 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service





Category:   Application (Generic)  >   Apache Subversion Vendors:   subversion.tigris.org
Subversion Windows Client Input Validation Flaw in filename Parameter Lets Remote Authenticated Users Create/Overwrite Files
SecurityTracker Alert ID:  1018617
SecurityTracker URL:  http://securitytracker.com/id/1018617
CVE Reference:   CVE-2007-3846   (Links to External Site)
Date:  Aug 29 2007
Impact:   Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 1.4.5
Description:   A vulnerability was reported in Subversion. A remote authenticated user can create or overwrite files on the target user's system.

The Windows-version client software does not properly validate user-supplied input in the filename parameter. A remote authenticated user with write privileges on the subversion server can supply a specially crafted value containing the "..\" directory traversal characters for a filename to cause files to be created or overwritten on the target user's system when the target user performs a checkout or update.

The original advisory is available at:

http://crisp.cs.du.edu/?q=node/36

Nils Durner and Christian Grothoff of the Colorado Research Institute for Security and Privacy reported this vulnerability.

Impact:   A remote authenticated user with write privileges on the subversion server can cause files to be created or overwritten on the target user's system.
Solution:   The vendor has issued a fixed version (1.4.5).
Vendor URL:  subversion.tigris.org/servlets/NewsItemView?newsItemID=1941 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2018, SecurityGlobal.net LLC