SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   IBM AIX Vendors:   IBM
IBM AIX pioout Command Lets Local Users Load and Execute Arbitrary Code
SecurityTracker Alert ID:  1018466
SecurityTracker URL:  http://securitytracker.com/id/1018466
CVE Reference:   CVE-2007-4003   (Links to External Site)
Date:  Jul 26 2007
Impact:   Execution of arbitrary code via local system, Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.2, 5.3
Description:   A vulnerability was reported in IBM AIX. A local user can obtain elevated privileges on the target system.

A local user can invoke the pioout command to cause the system to load an arbitrary library file and execute the file with root privileges.

The vendor was notified on June 5, 2007.

The vendor credits iDefense with reporting this vulnerability.

Impact:   A local user can obtain root privileges on the target system.
Solution:   The vendor plans to issue the following fixes.

For 5.2.0: IZ01121, available 10/31/2007
For 5.3.0: IZ01122, available 08/08/2007

An interim fix is available at:

ftp://aix.software.ibm.com/aix/efixes/security/pioout_ifix.tar.Z

Vendor URL:  www.ibm.com/ (Links to External Site)
Cause:   Access control error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC