SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Adobe Flash Player Vendors:   Adobe Systems Incorporated
Adobe Flash Player Bugs Let Remote Users Execute Arbitrary Code or Conduct Cross-Site Request Forgery Attacks
SecurityTracker Alert ID:  1018359
SecurityTracker URL:  http://securitytracker.com/id/1018359
CVE Reference:   CVE-2007-3456, CVE-2007-3457   (Links to External Site)
Date:  Jul 11 2007
Impact:   Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.0.45.0 and prior 9.0 versions, 8.0.34.0 and prior 8.0 versions, and 7.0.69.0 and prior 7.0 versions
Description:   Two vulnerabilities were reported in Adobe Flash Player. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted SWF file that, when loaded by the target user, will trigger an input validation flaw and execute arbitrary code on the target system [CVE-2007-3456]. The code will run with the privileges of the target user.

A remote user can send a specially crafted HTTP Referer value to conduct cross-site request forgery attacks [CVE-2007-3457]. Flash Player 9 is not affected.

Adobe credits Stefano DiPaola, Elia Florio, and Giorgio Fedon with reporting the input validation vulnerability and Daiki Fukumori of Secure Sky Technology, Inc. with reporting the HTTP Referer vulnerability.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can conduct cross-site request forgery attacks.

Solution:   The vendor has issued a fixed version (9.0.47.0), available at:

http://www.adobe.com/go/getflashplayer/

A patch for Flash 7 users is also available.

The Adobe advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb07-12.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb07-12.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (macOS/OS X), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 12 2007 (Red Hat Issues Fix) Adobe Flash Player Bugs Let Remote Users Execute Arbitrary Code or Conduct Cross-Site Request Forgery Attacks
Red Hat has released a fix for Red Hat Enterprise Linux Extras 3, 4, and 5.
Dec 12 2007 (Sun Issues Fix for Solaris) Adobe Flash Player Bugs Let Remote Users Execute Arbitrary Code or Conduct Cross-Site Request Forgery Attacks
Sun has issued a fix for Solaris 10.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC