SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Glibc Vendors:   GNU [multiple authors]
Glibc LD_HWCAP_MASK Integer Overflow Lets Local Users Execute Arbitrary Code
SecurityTracker Alert ID:  1018334
SecurityTracker URL:  http://securitytracker.com/id/1018334
CVE Reference:   CVE-2007-3508   (Links to External Site)
Date:  Jul 5 2007
Impact:   Execution of arbitrary code via local system, User access via local system

Version(s): 2.6
Description:   A vulnerability was reported in Glibc. A local user may be able to obtain elevated privileges on the target system.

A local user can set a specially crafted value for LD_HWCAP_MASK to trigger an integer overflow and potentially execute arbitrary code on the target system.

Tavis Ormandy of the Gentoo Linux Security Team discovered this vulnerability.

Impact:   A local user may be able to obtain elevated privileges on the target system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  directory.fsf.org/GNU/glibc.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC