SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   OS (UNIX)  >   OpenBSD Kernel Vendors:   OpenBSD
OpenBSD 'ld.so(1)' May Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1017253
SecurityTracker URL:  http://securitytracker.com/id/1017253
CVE Reference:   CVE-2006-6164   (Links to External Site)
Updated:  May 27 2008
Original Entry Date:  Nov 20 2006
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.9, 4.0
Description:   A vulnerability was reported in OpenBSD in 'ld.so(1)'. A local user may be able to obtain elevated privileges on the target system.

'ld.so(1)' does not properly reset user-supplied environment variables. This may theoretically allow a local user to obtain information or potentially obtain elevated privileges. However, the vendor notes that they have not identified any cases in which this would result in a security impact.

Only ELF-based systems are affected. m68k, m88k, and vax are a.out-based systems and are not affected.

Impact:   A local user may potentially be able to obtain information or elevated privileges on the target system.
Solution:   The vendor has issued the following patches.

ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.0/common/005_ldso.patch
ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.9/common/016_ldso.patch

Vendor URL:  www.openbsd.org/ (Links to External Site)
Cause:   Input validation error, State error

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC