SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Red Hat Package Manager (rpm) Vendors:   Red Hat
RPM Lets Remote Users Cause Arbitrary Code to Be Executed When Queried in Certain Locales
SecurityTracker Alert ID:  1017160
SecurityTracker URL:  http://securitytracker.com/id/1017160
CVE Reference:   CVE-2006-5466   (Links to External Site)
Date:  Nov 6 2006
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Red Hat Package Manager (rpm). A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted RPM package that, when queried by the target user with certain locales specified, will trigger a buffer overflow and execute arbitrary code on the target system. The code will run with the privileges of the target user.

The 'LANG=ru_RU.UTF-8' locale can trigger the flaw. The flaw is not triggered by the C and English locales.

Vladimir Mosgalin reported this vulnerability.

Impact:   A remote user can create an RPM package that, when queried by the target user, will execute arbitrary code on the target user's system.
Solution:   A fix is available via CVS.

A patch is available at:

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=139715

Vendor URL:  www.redhat.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC