SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   Dtmail Vendors:   HPE
(HP Issues Fix for Tru64 UNIX) HP UNIX Dtmail Buffer Overflow Lets Local Users Gain Root Privileges
SecurityTracker Alert ID:  1017099
SecurityTracker URL:  http://securitytracker.com/id/1017099
CVE Reference:   CVE-2006-5452   (Links to External Site)
Updated:  Jun 3 2008
Original Entry Date:  Oct 20 2006
Impact:   Execution of arbitrary code via local system, Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Dtmail on Tru64 UNIX and HP-UX. A local user can obtain elevated privileges on the target system.

A local user can invoke dtmail with the '-a' switch to trigger a buffer overflow to execute arbitrary code on the target system.

Adriel T. Desautels of Netragard reported this vulnerability.

The original advisory is available at:

http://www.netragard.com/pdfs/research/HP-TRU64-DTMAIL-20060810.txt

[Editor's note: The advisory refers to HP Tru64 UNIX. However, HP has indicated that dtmail on HP-UX is also affected.

Impact:   A local user can obtain root privileges on the target system.
Solution:   HP has issued the following Early Release Patch kits.

HP Tru64 UNIX Version 5.1B-3 ERP Kit

Location: http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1000912-V51BB26-ES-20060928

Name:T64KIT1000912-V51BB26-ES-20060928.tar

MD5 Checksum: bca42343837c9df40278db23a8e937d7

HP Tru64 UNIX Version 5.1B-2/PK4 ERP Kit

Location: http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1000908-V51BB25-ES-20060928

Name: T64KIT1000908-V51BB25-ES-20060928.tar

MD5 Checksum: cd372a1eee401c287216e0a803cdfde2

HP Tru64 UNIX Version 5.1A PK6 ERP Kit

Location: http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1000916-V51AB24-ES-20060929

Name: T64KIT1000916-V51AB24-ES-20060929.tar

MD5 Checksum: bcf69e1de05b7bcb611dcff9b62f440

HP Tru64 UNIX Version 4.0G PK4 ERP Kit

Location: http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1000911-V40GB22-ES-20060928

Name: T64KIT1000911-V40GB22-ES-20060928.tar

MD5 Checksum: 6c5dda9fe09c1a40ef4ed83e1cf01e14

HP Tru64 UNIX Version 4.0F PK8 ERP Kit

Location: http://www2.itrc.hp.com/service/patch/patchDetail.do?patchid=DUXKIT1000913-V40FB22-ES-20060928

Name: DUXKIT1000913-V40FB22-ES-20060928.tar

MD5 Checksum: 9bdf70afb5fafc8e39396925bd9c517b

The HP advisory is available at:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00793805

Vendor URL:  www.hp.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  UNIX (Tru64)
Underlying OS Comments:  4.0F PK8, 4.0G PK4, 5.1A PK6, 5.1B-2/PK4, 5.1B-3

Message History:   This archive entry is a follow-up to the message listed below.
Oct 18 2006 HP UNIX Dtmail Buffer Overflow Lets Local Users Gain Root Privileges



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC