SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Mono Vendors:   mono-project.com
Mono Web Server 'xsp' Component Lets Remote Users Traverse the Directory
SecurityTracker Alert ID:  1016821
SecurityTracker URL:  http://securitytracker.com/id/1016821
CVE Reference:   CVE-2006-2658   (Links to External Site)
Date:  Sep 11 2006
Impact:   Disclosure of system information, Disclosure of user information


Description:   A vulnerability was reported in the Mono/C# web server. A remote user can view files on the target system.

The 'xsp' component used by mod_mono does not properly validate user-supplied input. A remote user can supply an HTTP request with a specially crafted relative path name to view files on target system that are located outside of the document directory.

Impact:   A remote user can view files on the target system.
Solution:   A fix for SUSE Linux is available from Novell/SUSE.

The Novell advisory is available at:

http://www.novell.com/linux/security/advisories/2006_22_sr.html

[Editor's note: It is unclear which upstream version is affected.]

Vendor URL:  www.mono-project.com/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC